Facebook XMPP appears to be connecting "sort of" and then failing

Description

Upon connecting to Facebook via XMPP we get a list of some roster items and such .. and then for some reason we get a "service unavailable" and disconnection. Currently the transport treats this as a failed password which is incorrect, but none-the-less it's not behaving right. Error looks like this:

<code>
2010.07.09 14:55:39 facebook user's login/password does not appear to be correct
: jadestorm
service-unavailable(503)
at org.jivesoftware.smack.NonSASLAuthentication.authenticate(NonSASLAuth
entication.java:77)
at org.jivesoftware.smack.SASLAuthentication.authenticate(SASLAuthentica
tion.java:352)
at org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:230)
at net.sf.kraken.protocols.xmpp.XMPPSession$1.run(XMPPSession.java:267)
2010.07.09 14:55:39 Disconnecting session daniel@vorpalcloud.org from facebook.v
orpalcloud.org
2010.07.09 14:55:39 facebook: Sending packet: <presence type="unavailable" to="d
aniel@vorpalcloud.org" from="facebook.vorpalcloud.org"/>
2010.07.09 14:55:39 facebook: Sending packet: <message type="error" from="facebo
ok.vorpalcloud.org" to="daniel@vorpalcloud.org/GHIDORA"><body>The password you r
egistered with is incorrect. Please re-register with the correct password.</bod
y><error code="500" type="wait"><undefined-condition xmlns="urn:ietf:params:xml:
ns:xmpp-stanzas"/></error></message>
</code>

Note the bizarreness that this is AFTER I've gotten some presence notifications and such?

?!

Environment

None

Activity

Show:
daniel vultur
September 21, 2010, 10:27 PM

This has been resolved.

Fixed

Assignee

Daniel Henninger

Reporter

Daniel Henninger

Labels

None

Expected Effort

None

Ignite Forum URL

None

Components

Fix versions

Affects versions

Priority

Blocker