Fastpath now has JiveSharedSecretSaslServer requirement found in 4.1 Openfire

Description

There was just a trivial forms update in 4.4.1, but after the update the plugin doesn't load. It now requires 4.0.0 of Openfire, maybe it was built with new Java and it doesn't support it? 4.4.0 version works fine. Logs:

Environment

None

Activity

Show:
Daryl Herzmann
December 2, 2016, 3:27 PM

Simple issue here, https://github.com/igniterealtime/Openfire/commit/9017ee09cce6aed007425a15fc563c6af07e2f24#diff-03ea494c60f6a866a55fe8c616a65bee introduced code into fastpath for `org.jivesoftware.openfire.sasl.JiveSharedSecretSaslServer`, we just need to bump minVersion for fastpath in master to 4.1

wroot
December 1, 2016, 7:13 PM

Actually i have filed another one for 4.1.0 https://issues.igniterealtime.org/browse/OF-1230

Daryl Herzmann
December 1, 2016, 6:58 PM

So there are some things here I am not understanding with how the fastpath plugin builds. Will have to review this for 4.1 openfire release.

wroot
December 1, 2016, 6:51 PM

Yes, this one works.

Fixed

Assignee

Daryl Herzmann

Reporter

wroot

Labels