We're updating the issue view to help you get more done. 

Introduce 'priorToServerVersion' for plugins

Description

Plugins can define a minServerVersion in plugin.xml, which defines the minimum version of Openfire that is required to run the plugin. A similar attribute that defines the maximum version, or a version on or after which a plugin can no longer be used, should be added.

This feature could be used for plugins of which the functionality has been merged into Openfire's core code at some point. When that happens, it no longer makes sense to have the plugin loaded, as that would then offer a duplicate (potentially conflicting) implementation.

Environment

None

Acceptance Test - Entry

None

Activity

Show:
Guus der Kinderen
June 24, 2017, 1:38 PM

Instead of maxServerVersion I went with priorToServerVersion which describes better that the value is exclusive - the plugin will work up to, but not including, the specified version.

Assignee

Dave Cridland

Reporter

Guus der Kinderen

Labels

None

Expected Effort

None

Ignite Forum URL

None

Components

Fix versions

Priority

Minor
Configure