We're updating the issue view to help you get more done. 

Drop Java 7 Support

Description

The next scheduled major release of Openfire is version 4.2.0.  The current thought is that once 4.2 is branched, we will march master branch to support only Java 8+.  Community feedback is certainly welcome.

Environment

None

Acceptance Test - Entry

None

Activity

Show:
Greg Thomas
April 11, 2018, 2:09 PM

Note; until we upgrade to Jetty 9.3.6 or higher, it's not possible to use Java 8 idioms (e.g. lamdas) in JSP pages.

It's necessary to set the sourceVersion/targetVersion in the Jetty Jspc Maven Plugin, something not available before that version. 

https://www.eclipse.org/jetty/documentation/current/jetty-jspc-maven-plugin.html

wroot
April 11, 2018, 3:11 PM

Maybe you should create new ticket for this, so it won't get overlooked and maybe also a ticket to update Jetty at some point and revert jspc changes.

Greg Thomas
April 11, 2018, 3:24 PM
Fixed

Assignee

Dave Cridland

Reporter

Daryl Herzmann

Labels

None

Expected Effort

None

Ignite Forum URL

None

Fix versions

Priority

Major
Configure