We're updating the issue view to help you get more done. 

Remove dependency on commonshttpclient version 3.1

Description

Openfire currently uses commons-httpclient : commonshttpclient : 3.1 - this is EOL (http://hc.apache.org/httpclient-3.x/) and should be replaced with the Apache HttpComponents HTTP client.

Note; version 4.5.5 of the Apache HttpComponents HTTP client is already a dependency.

Environment

None

Acceptance Test - Entry

None
Fixed

Assignee

Greg Thomas

Reporter

Greg Thomas

Labels

None

Expected Effort

None

Ignite Forum URL

None

Components

Fix versions

Affects versions

Priority

Major
Configure