Update junit + mockito test dependencies

Description

Openfire 4.2.3 uses 

junit:junit:4.11 and org.mockito:mockito-core:2.10.0

The current versions are

junit:junit:4.12 and org.mockito:mockito-core:2.19.0

Environment

None
Fixed

Assignee

Greg Thomas

Reporter

Greg Thomas

Labels

None

Expected Effort

None

Ignite Forum URL

None

Components

Fix versions

Affects versions

Priority

Major
Configure