PubSubPersistenceManager.purgeItems incompatibility with Oracle DB

Description

From the forums;

This is related to .

It looks like the SQL used in the batch to select from OFPUBSUBITEM has a ‘LIMIT’ which is not supported by both Oracle DB and DB2. This makes the purging of OFPUBSUBITEM constantly fail.
Found in 3.9.3, but as far as I can see, it is present in newer versions as well.

Environment

None

Activity

Show:
Greg Thomas
March 27, 2019, 10:19 AM

Note: PR as submitted only support Oracle, closing this ticket, will create another for DB2 

Fixed

Assignee

Greg Thomas

Reporter

Greg Thomas