Update installation guide

Description

Installation guide lists only RPM and tar.gz for Linux and assumes that RPM is bundled with JRE. But there are also variants without JRE and also deb installer currently.

Maybe also add a stub for macOS installation, although i can't provide details on that.

Also it mentions that Openfire needs Java 1.7.0 or later. This could be clarified that Openfire 4.3 needs Java 8, and 4.4.0 works with Java 11.

Environment

None
Fixed
Your pinned fields
Click on the next to a field label to start pinning.

Assignee

wroot

Reporter

wroot