Ant buildscript should not check for explicit Ant version numbers


Currently, the ant buildscript checks if the version of Ant that is being used is either 1.6 or 1.7. This causes a problem for people using newer versions. The buildscript should specify a minimum version of Ant, and assume that all future versions will be backwards compatible.




Guus der Kinderen
September 29, 2015, 11:59 AM

Created a PR for this here:

Sadly, the same cannot be done (easily) for Java version. I added Java 1.9 to be somewhat future proof for a while.

Note that this commit also raises the minimum version of Ant from 1.6 (released in 2003/2004) to 1.7.1 (released: 2008) (the Ant version check itself was added in 1.7).

Guus der Kinderen
November 1, 2013, 1:42 PM

We'll likely replace Ant with Maven starting from Openfire 4.x.

November 1, 2013, 1:35 PM

So, we will have to release "bandaid" fixes with every new Ant version.

Guus der Kinderen
February 6, 2013, 7:57 PM

Removing the 'fix version' for all unresolved issues that were scheduled for version 7.8.2. We're releasing this version today - the remaining issues should be rescheduled later.

Daryl Herzmann
July 16, 2010, 2:13 AM

Committed r11768 as a bandaid to support ant 1.8 . Necessary to get it building on our new build farm, I think. re)

Your pinned fields
Click on the next to a field label to start pinning.




Guus der Kinderen