We're updating the issue view to help you get more done. 

Update installation package with the latest Java JRE (1.7.0_2 or higher)

Description

Support for Java 6 ends in summer 2012.
Support for Java 5 should also be dropped, EOL was long ago.

Environment

None

Acceptance Test - Entry

None

Activity

Show:
Neustradamus
February 5, 2014, 10:30 PM

Please update JRE to 7u51.

Daryl Herzmann
February 6, 2014, 4:15 PM

I'll be fixing this once the bamboo fiasco clears. I've been poking around and see how things are working now, I hope.

Neustradamus
February 6, 2014, 7:48 PM

Thanks

It will be nice to have a ticket always open, when you release a new version, always update Java JRE version in the same time!

Daryl Herzmann
February 6, 2014, 8:44 PM

Relevant build logs

wroot
February 6, 2014, 9:25 PM

I don't like keeping the same ticket open forever. This will mean it isn't resolved for many years. I think after closing laast one, new one must be filed for the next Openfire release. Though, updating Java to the latest version (which can be a few days old) when doing a release can be risky. I don't remember new Java version causing troubles to Openfire, but in desktop versions it sometimes does.

Fixed

Assignee

Daryl Herzmann

Reporter

LG

Labels

None

Expected Effort

None

Ignite Forum URL

None

Components

Fix versions

Affects versions

Priority

Major
Configure