We're updating the issue view to help you get more done. 

GoJara plugin library has Java-6 code

Description

The GoJara plugin uses a library named json.jar. This library was compiled in a fashion incompatible with Java 5. This causes compilation to fail (Openfire requires Java 5, not 6):

The offending jar should be replaced with a Java 5 compatible equivalent (with a bit of luck, it needs recompilation only).

Environment

None

Acceptance Test - Entry

None

Activity

Show:
Guus der Kinderen
February 16, 2013, 7:46 PM
  • The json.jar library that is included with the plugin was replaced with a variant that was compiled using Java 5

  • @Override annotations have been removed from methods that implement an interface (again, not valid in Java 5).

Assignee

Holger Bergunde

Reporter

Guus der Kinderen

Expected Effort

None

Ignite Forum URL

None

Fix versions

Affects versions

Priority

Major
Configure