We're updating the issue view to help you get more done. 

Migrate license from GPL to Apache 2.0

Description

Move Openfire from GPL to Apache 2.0 license. Apache 2.0 is a more liberal license that offers greater flexibility to the community vs. GPL.

Environment

None

Acceptance Test - Entry

None

Activity

Show:
Guus der Kinderen
February 1, 2010, 9:09 PM

I've been unable to get a response from Matt in the past few days. I assume that the licence header on admin pages should indeed be changed too. They are, after all, part of the product that will be released under the Apache license.

Guus der Kinderen
February 1, 2010, 9:47 PM

Done for /src/web/ There are a couple of plugins left. Should we update their version number, if we modify the license information?

Guenther Niess
February 1, 2010, 10:25 PM
Edited

I remember that you already updated a couple of the plugins with a new version for the SLF4J usage. I would vote to update the version of the remains if there are any. And by the way maybe we should also reflect the the new version 3.7.0 instead of 3.6.5 (minServerVersion in the plugin.xml files).

Guus der Kinderen
February 1, 2010, 10:49 PM

Good point. I just made these changes.

Guus der Kinderen
February 1, 2010, 11:32 PM

I think we're there.

Assignee

MattM

Reporter

MattM

Labels

None

Expected Effort

None

Ignite Forum URL

None

Components

Fix versions

Affects versions

Priority

Major
Configure