We're updating the issue view to help you get more done. 

Flash client connection closing with invalid_namespace error

Description

New install of 3.9.2 and when I put Sparkweb on my webserver and try to login to it the page refreshes and nothing happens.

The logs show.

2014.05.03 21:58:57 org.jivesoftware.openfire.net.StanzaHandler - Closing session due to invalid_namespace in stream header. Namespace: http://www.jabber.com/streams/flash. Connection: org.jivesoftware.openfire.nio.NIOConnection@1316347 MINA Session: (SOCKET, R: /REMOVED:56704, L: /REMOVED:5222, S: 0.0.0.0/0.0.0.0:5222)

Environment

SparkWeb (probably other flash clients)

Acceptance Test - Entry

None

Activity

Show:
wroot
May 15, 2014, 4:01 AM

Looks like related changes in 3.9.2: OF-183,

csh
May 17, 2014, 10:39 PM

Yes, I've made this change () because http://xmpp.org/rfcs/rfc6120.html#streams-ns-stream says so.

http://www.jabber.com/streams/flash is an invalid namespace, but it seems like Flash needs it. Maybe we should just check both.

David Gonzalez
May 30, 2014, 1:25 PM

I download the version OpenFire 3.9.3-1 on the official website of Ignite, and the 0.9.0 of SparWeb. I install whit external DB MySQL. My OpenFire work fine whit the other clients (pidggin, spark, kopete, etc...) but whit the SparkWeb at time to login comeback to the login screen.

The error in the log:
2014.05.30 08:02:05 org.jivesoftware.openfire.net.StanzaHandler - Closing session due to invalid_namespace in stream header. Namespace: http://www.jabber.com/streams/flash. Connection: org.jivesoftware.openfire.nio.NIOConnection@d944e1 MINA Session: (SOCKET, R: /xxx.xxx.xxx.xxx:58033, L: /xxx.xxx.xxx.xxx:5222, S: 0.0.0.0/0.0.0.0:5222)

I follow this ticket, but no can found any solution... or i not understand the solution... please some step by steep i need follow for work.

I used CentOS 5.10.

wroot
May 31, 2014, 9:17 AM

Please, do not ask questions here. Go to the linked Ignite Forum URL https://community.igniterealtime.org/message/239329#239329
This issue will be fixed in the 3.9.4 version and there is no solution so far. You can use 3.9.1 version for now https://igniterealtime.org/downloads/download-landing.jsp?file=openfire/openfire_3_9_1.exe

Assignee

Guus der Kinderen

Reporter

wroot

Expected Effort

None

Ignite Forum URL

None

Fix versions

Affects versions

Priority

Major
Configure