Fastpath request getting stuck when using multiple MUC services

Description

On the 3.9.3 server, I had a user use Spark and open a chat to a FastPath workgroup. FastPath is not passing the session off to a member of the workgroup.

On the 3.8.2 server, it behaves properly. The chat request is passed off to an agent to accept and the chat is established. All good.

The problem is certainly an issue in the integration between FastPath and OpenFire. The latest FastPath works with OpenFire 3.8.2, so I'm guessing something on OpenFire 3.9.x

It seems that FastPath is unable to handle having more than one group chat service defined.

In addition to the default "conference" service that is default, I had several other group conference services defined. Deleting all conference services but the default and all workgroups, then restarting the server, and creating the new FastPath workgroups seems to have solved this issue.

Environment

None

Activity

Show:
Daryl Herzmann
January 7, 2019, 3:40 AM
Daryl Herzmann
October 31, 2015, 3:23 AM

I suspect this is still the case with 3.10.2, but can anybody confirm?

Jay
October 21, 2014, 7:43 AM
Edited

We are only seeing the same problem after updating from 3.9.1 to 3.9.3. So it was generally working with 3.9.1 for us. We are also only using the default conference service, without multiple services defined. After downgrading to 3.9.1 it is working again.

wroot
June 2, 2014, 7:54 PM

Maybe not related, but Spark is also often getting confused when multiple conference services are available.

Moved to GH

Assignee

Unassigned

Reporter

wroot