Rename RosterEntry.getStatus and RosterPacket.ItemStatus to ItemAskStatus

Description

The current name is misleading, as it makes users think it's related to the subscription status.

Environment

None
Fixed

Assignee

Florian Schmaus

Reporter

Florian Schmaus

Labels

Expected Effort

Medium

Ignite Forum URL

None

Components

Fix versions

Affects versions

Priority

Major
Configure