Chat window is not flashing when receiving new message

Description

I can't find a way to reproduce it properly, but it happens too often, as i have switched to the 11362 SVN build (was using Beta). Usually this happens when i get first message after i login to Spark. Any subsequent messages doesnt make chat window to flash in the taskbar either. But if i try to login with another messenger on the same computer and then send a message to my JID on Spark, then it starts flashing. Also if i go to Preferences and uncheck, check again Flashes and save, this seems to fix this issue for a moment.

This ticket needs further investigation to find proper way to reproduce it.

Environment

Windows XP

Activity

Show:
wroot
March 22, 2011, 10:40 AM

Working so far. Will test more next week at work. Closing.

Wolf P.
March 22, 2011, 8:34 AM
Edited

test now
i tested with öäü╦§ƒ☺šč and seems to work

Walter Ebeling
March 17, 2011, 7:55 PM

Updateing to blocker, since this will cause a bit of trouble with the client.

wroot
March 17, 2011, 1:40 PM

Looks like it. I was suspecting some name mismatch between tab and flashing code. Hope you can fix this Probably 90% of our personnel has utf chars in names

Wolf P.
March 17, 2011, 1:15 PM

problem is in windows api and flashingdll, winapi uses ASCII and Java passes Unicode to DLL

[code]
const char* cWindowTitle = env->GetStringUTFChars(windowTitle, 0);
/code
is unicode unfriendly

const wchar_t* should be used,probably dunno need to find out

Fixed

Priority

Blocker

Assignee

Wolf P.

Reporter

wroot