Spark should check for newer plugins and emoticons version on startup and extract them

Description

Currently if you install updated Spark version with changed emoticons (and i suspect plugins) it won't extract new versions if these files are already in user's profile. So admins has to do additional scripts wiping plugins and xtra folders for users. Should be automatic.

Environment

None

Activity

Show:
Tim Jentz
August 15, 2013, 8:26 AM

Can you give me an example for the plugins?
I locally changed two plugins for testing and build them. After installing this local spark build, the plugins i've changed replaced the old ones.

wroot
August 15, 2013, 8:46 AM

I was under impression plugins should behave similarly. And i think in the past while building Spark with plugins i had some issues, but i can't remember now. If it updates correctly then it is fine, and if your emoticons patch fixes all emoticons packs (if they will update in the future), then we can close this ticket (and the POPO one, i have tested it and it works fine).

Assignee

Unassigned

Reporter

wroot

Expected Effort

None

Ignite Forum URL

None

Components

Affects versions

Priority

Major
Configure