Shows empty status field after going to idle and back to Invisible

Description

When someone sets Invisible status and then idle kicks in, the icon switches to Away and the status text goes away. When a user is active again, the status text doesn't reappear, though it now shows the correct invisible icon. This only affects the user having Invisible set. Others see him as offline all the time. This can be easily fixed by selecting Invisible again. Or one might not as well care about it.

Environment

None

Activity

Show:
wroot
March 29, 2021, 7:15 PM

Another side effect is that my Spark hangs after switching to Invisible without status text.

Andrew Prusinowski
October 7, 2020, 2:34 AM

Ahh, appreciate the clarification - a bit different than what I was expecting.  I'll look into it

wroot
October 6, 2020, 4:14 PM

Just tested again on the latest version and can still reproduce.

Run Spark and login.

Switch to Invisible. It shows gray icon and text "Invisible" below your nickname.

Wait until Spark goes idle (set idle to 1 minute to make it idle out faster).

It switches to Away state and status text disappears. It only shows yellow icon below nickname, but no "Away" text.

If you move your mouse it goes back to gray icon, but no "Invisible" text is shown.

Andrew Prusinowski
October 6, 2020, 1:39 PM

@wroot I was unable to reproduce this bug using the newest build.  After setting my status as invisible with a custom message, going idle, then returning from idle (shaking mouse), the old custom invisible status message was restored.  Are there any particular steps required to reproduce this?

Priority

Minor

Assignee

Unassigned

Reporter

wroot