Admin console erroneously reports errors over min plugin versions

Description

Steps to reproduce;

  1. Run Openfire 4.3.0 Alpha

  2. Install a plugin with a minServerVersion of 4.3.0

  3. Examine the Plugins screen on the admin console

Expected results:

  • The admin console shows the installed plugin

Actual results:

  • The admin console shows the installed plugin, but with an error highlighted:

The version of the plugin that is installed requires Openfire 4.3.0 or later versions!

 

Environment

None
Fixed

Assignee

Greg Thomas

Reporter

Greg Thomas

Labels

None

Expected Effort

None

Ignite Forum URL

None

Components

Fix versions

Affects versions

Priority

Major
Configure