Update MySQL Connector/J to version 8.0.17

Description

Openfire currenty uses 8.0.12, for which at least two CVE's have been published:

Updating to the latest patch-release should be a low risk way to mitigate these issues.

Environment

None

Acceptance Test - Entry

None
Fixed

Assignee

Guus der Kinderen

Reporter

Guus der Kinderen

Labels

None

Expected Effort

None

Ignite Forum URL

None

Components

Fix versions

Priority

Major
Configure