We're updating the issue view to help you get more done. 

Update Tinder to 1.2.1

Description

Update the Tinder library to version 1.2

Environment

None

Acceptance Test - Entry

None

Activity

Show:
Guus der Kinderen
November 17, 2009, 3:45 AM

I'm puzzled: how do you get the original error? org.jivesoftware.openfire.launcher.Launcher uses the rt.jar in jre 1.5 when resolving the org.w3c.dom package in Eclipse.

Guus der Kinderen
December 2, 2009, 3:26 AM

I'm going to tackle this in another way: Prior to Tinder, whatever dependencies where needed were already in Openfire. I didn't remove any of those libraries, so they should still be there. I did however add more of the same, by packaging them in the Tinder-with-Dependencies jar. This might account for the problems that you're seeing. I will replace the -with-dependencies with a jar without them. Instead, I will add the dependencies separately. Dom4j is already in there, so I'll not add another one. This should avoid an additional xml-apis.jar in your eclipse. At the very least, it will restore the state of the project to what it was before Tinder was added.

Guus der Kinderen
December 2, 2009, 4:01 AM

Done.

I have replaced the StringPrep jar with LibIDN. This is a dependency of Tinder and an updated variant of StringPrep. The libraries are interchangable, with the exception of package definitions.

Guus der Kinderen
January 2, 2010, 8:52 PM

We should update to 1.2.1, because of

Guus der Kinderen
January 2, 2010, 9:01 PM

Done (no-one notices that I didn't actually release 1.2.1 yet, right )

Fixed

Assignee

Guus der Kinderen

Reporter

Guus der Kinderen

Labels

None

Expected Effort

None

Ignite Forum URL

None

Components

Fix versions

Affects versions

Priority

Minor
Configure